Запуск OS/2. Помогите!... - Форум
Пользовательского поиска
Среда, 18.01.2017, 23:12
Приветствую Вас Гость | RSS
Главная | Запуск OS/2. Помогите!... - Форум | Регистрация | Вход
Меню Проекта
Форма входа
Логин:
Пароль:
Мы Рекомендуем:
Мнение Общественности
Какую файловую систему на флешке вы предпочитаете?
1. NTFS
2. FAT-16/32
3. Ext-2/3
4. Другую
Всего ответов: 4910
Статистика
GreenFlash
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Модератор форума: Sh1td0wn 
Форум » Мультизагрузочная флешка » Общий » Запуск OS/2. Помогите!... (Имеется образ IMA с полуосью, не работает)
Запуск OS/2. Помогите!...
HancTepДата: Среда, 12.11.2014, 19:47 | Сообщение # 1
Неизвестный
Группа: Пользователи
Сообщений: 2
Репутация: 0
Статус: Отсутствует
Приветствую, форумчане!

[предыстория]

Для служебных нужд (инициализация некоторого оборудования) использую загрузку системы с дискеты. Для упрощения жизни и сокращения трат на дискеты решил все рабочие утилиты объединить на одном загрузочном диске.
Все работает кроме одного образа.Дискета построена на основе старушки OS/2, в которой я вообще ничего не понимаю. Если есть знающие полуось, огромная просьба откликнуться.

Для проверки работы диска использовал VirtualBox, QEMU, реальный ноутбук

При монтировании образа IMA в флопик виртуальной машины загрузка успешная (скриншот 3).
При монитровании созданного в неро самозагружаемого ISO (iepp3.iso), в загрузочной области которого образ IMA, в привод виртупльной машины загрузка успешная (скрин 3)
При монтировании такого же ISO  (iepp2.iso) , но еще с распакованным образом IMA в корне диска, также загрузка успешная.

Эти два ISO в неро содавал с эмуляцией флоппи 1.44, сегмент загрузки секторов 07C0 (по умолчанию), режим данных Mode1, файловая система ISO9660+Joilet, набор символов DOS.

[суть проблемы]

Мультизагрузочный диск создавал с помощью GRUB4ISO (BAT-файл для запуска сборки ISO прилагаю - make.bat). Подозреваю, что в нем что-то не так.
При запуске с мультизагрузочного ISO ни один из трех вариантов не работает. Сама полуось начинает загружаться, но:
- при запуске IMA - ошибка на скрине 2.
- при запуске iepp2.iso или iepp3.iso - ошибка на скрине 1.

[Прилагаемые файлы]
- image.ima (исходный образ дискеты)
- iepp3.iso (создан в неро с образом IMA в качестве образа загрузки)
- menu.lst (перепробованные варианты запуска)
- скриншоты ошибок и скриншот того,что должно быть на экране при удачном запуске
- make.bat (скрипт создания образа grub4iso)

В архиве нет образа iepp2.iso, т.к. на форуме ограничение на объем файла, но этот образ тот же iepp3.iso с файлами из образа дискеты в корне.
Прикрепления: 1367431.rar(1761Kb)


Сообщение отредактировал HancTep - Среда, 12.11.2014, 19:50
 
AtlantДата: Четверг, 13.11.2014, 00:08 | Сообщение # 2
Мастер
Группа: Проверенные
Сообщений: 2075
Репутация: 195
Статус: Отсутствует
Самым прстым и правильным меню будет:
Код
title Image  
map --mem /image.mg (fd0)  
map --hook
rootnoverify (fd0)
chainloader (fd0)+1

Но оно не работает, собственно я сомневаюсь что Grub4Dos умеет запускать OS/2 (ее загрузчик - EXTBOOT). По спрашивай лучше на reboot.pro, там и автор часто заходит.
 
HancTepДата: Четверг, 13.11.2014, 21:44 | Сообщение # 3
Неизвестный
Группа: Пользователи
Сообщений: 2
Репутация: 0
Статус: Отсутствует
Да, такой вариант я также пробовал... Похоже надо попробовать другой загрузчик. Буду искать...
 
Форум » Мультизагрузочная флешка » Общий » Запуск OS/2. Помогите!... (Имеется образ IMA с полуосью, не работает)
Страница 1 из 11
Поиск:
Чат

Copyright GreenFlash © 2017
Рейтинг@Mail.ru